SYMPTOMS
Spell check in Outlook now checks the entire email instead of just the newly composed text
CAUSE:
This problem can sometimes be caused by enabling the "Automatically remove yourself after clicking Reply To All" option in the Reply To All Monitor add-in.
RESOLUTION:
When using plain text on Outlook 2003 (or plain text in higher versions, or HTML in higher versions of Outlook, but NOT HTML in Outlook 2003), and having the "Automatically remove yourself after clicking Reply To All" option turned on, the spell checker will sometimes not ignore original message text in reply or forward messages.
When the second option of the add-in is enabled ("Automatically remove yourself after clicking Reply To All"), the add-in performs a save operation on the email in order to be able to "see" the list of recipients. It is during this save process that the start of the original email message is lost in the Outlook editor.
This bug has been confirmed on our systems and we are working on a fix. In the meantime (as a workaround), uncheck this option and the spell check will then behave as normal.