SYMPTOMS:
Cannot see the list of recurring emails and cannot add any new ones
CAUSE:
The "Scheduled Email" calendar cannot be found
RESOLUTION:
Schedule Recurring Email works by creating a calendar under the user's default Calendar called "Scheduled Email". The add-in caches that calendar's unique ID once it has been created for quick reference later. When a server change occurs, that ID is no longer valid.
To fix the problem, simply go into the add-in, select the "Settings" tab, then choose the "Change" button to pick (or create) a new Calendar folder. Note: while you can use your default calendar, this is not recommended since the times at which the scheduled emails are going to go out will show up as appointments, cluttering your regular calendar.
Once the new calendar is in place, be sure to restart Outlook.