SYMPTOMS
Email that was supposed to go out just sits there in the Drafts folder or the Outbox folder, until "Send/Receive" is clicked.
CAUSE
This problem applies to any add-in that sends email, including Schedule Recurring Email, Appointments By Email, Email Reminders, Secure Email Forward and Watch Outlook Folders. It could also affect add-ins that rely on the arrival of email in order to work, e.g., Attachment Save, File Fetch, and Auto Print.
RESOLUTION
Be sure that email is set to occur automatically on your system. Go to Tools...Options...Mail Deilvery (Note: it might say "Mail Setup" if you're connected to Microsoft Exchange Server). One of the options on that tab is to "Check for new messages every N minutes". Be sure that this checkbox is checked and that the number of minutes is something reasonable, 10 minutes or so. You may want to make this longer if you are dialing up and a little shorter if you are on broadband.